Subject: 143 - ___unvis13 redefinition
To: None <>
From: John Nemeth <>
List: tech-pkg
Date: 11/28/2004 15:54:22
     I'm trying to upgrade pkgsrc on my laptop which is running 1.4.3.
I haven't upgraded the laptop because it only had 8 MB of RAM and could
not reliably run the install, not to mention that it took days to
compile a stripped down kernel.  I now have 20 MB of RAM, the maximum
for my laptop, so I may try again some time.

     Anyways, I downloaded a current pkgsrc tarball, unpacked it, went
to /usr/pkgsrc/pkgtools/pkg_install, and tried to make install.  This
bombed miserably due to the use of makefile features not supported by
older versions of make.  So, I went to /usr/pkgsrc/bootstrap and tried
./bootstrap.  This bombed with:

     /tmp/cczolCwz.s: Assembler messages:
     /tmp/cczolCwz.s:36: Fatal error: Symbol ___unvis13 already defined.

So, being the clever sort, I grabbed the source for make from -current,
rebuilt make, and installed it.  Then I tried pkg_install again and it
bombed with the same error.  Does anybody have any clues?  I've placed
a complete log at .