Subject: glib2/gettext problem
To: None <>
From: Bernhard Riedel <bernhard@SDG.DE>
List: tech-pkg
Date: 11/27/2004 18:13:15

I can't build devel/glib2 because of something that looks like a gettext

beast# cd /usr/pkgsrc/devel/glib2
beast# make
checking if -liconv is needed to use gettext... 
checking for dcgettext in -lintl... no
configure: error:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. (

*** Error code 1

make: stopped in /big/usr/pkgsrc/devel/glib2
*** Error code 1

make: stopped in /usr/pkgsrc/devel/glib2
beast# uname -a
NetBSD beast 1.6.2 NetBSD 1.6.2 (BEAST) #0: Tue Sep 21 18:07:34 CEST 2004     root@beast:/big/usr/src/sys/arch/i386/compile/BEAST i386
beast# pkg_info | grep gette
gettext-m4-0.11.5   Autoconf/automake m4 files for GNU NLS library
gettext-lib-0.11.5nb4 Internationalized Message Handling Library (libintl)
gettext-0.11.5nb5   Tools for providing messages in different languages
beast# ls /usr/lib/libintl*
/usr/lib/libintl.a        /usr/lib/     /usr/lib/libintl_p.a
/usr/lib/       /usr/lib/   /usr/lib/libintl_pic.a
beast# grep -i gette Makefile
.include "../../devel/gettext-lib/"
beast# find work.beast/.buildlink | grep libintl

Then I did a pkg_delete on all gettext packages and tried again to build
 devel/glib2. Same error as above.

Many thanks to hubertf@, who suggested most of the tests above.
He was also able to reproduce the problem with 2.0RC5.

Cheers, Burnhard.