Subject: Re: security/openssh problem on Linux, Slackware 10.0
To: Jeremy C. Reed <>
From: Ben Collver <>
List: tech-pkg
Date: 11/27/2004 06:01:04
On Fri, Nov 26, 2004 at 11:42:14AM -0800, Jeremy C. Reed wrote:
> Run the sshd with debugging.
> Maybe you need PAM setup for it.

Thank you for the response.

Slackware 10.0 does not have PAM, pkgsrc did not install PAM, and
openssh was not linked to PAM, so I assume PAM is out of the picture.

I ran "/usr/pkg/sbin/sshd -ddd" and tried again.  Nothing different
showed up in the syslog.  I didn't see anything revealing in the
console output, but I am including it just in case.

Any ideas on a next step?


debug2: load_server_config: filename /usr/pkg/etc/ssh/sshd_config
debug2: load_server_config: done config len = 147
debug2: parse_server_config: config /usr/pkg/etc/ssh/sshd_config len 147
debug1: sshd version OpenSSH_3.9p1
debug1: private host key: #0 type 0 RSA1
debug3: Not a RSA1 key file /usr/pkg/etc/ssh/ssh_host_rsa_key.
debug1: read PEM private key done: type RSA
debug1: private host key: #1 type 1 RSA
debug3: Not a RSA1 key file /usr/pkg/etc/ssh/ssh_host_dsa_key.
debug1: read PEM private key done: type DSA
debug1: private host key: #2 type 2 DSA
debug1: rexec_argv[0]='/usr/pkg/sbin/sshd'
debug1: rexec_argv[1]='-ddd'
socket: Address family not supported by protocol
debug2: fd 3 setting O_NONBLOCK
debug1: Bind to port 22 on
Server listening on port 22.
Generating 768 bit RSA key.
RSA key generation complete.
debug3: fd 4 is not O_NONBLOCK
debug1: Server will not fork when running in debugging mode.
debug3: send_rexec_state: entering fd = 7 config len 147
debug3: ssh_msg_send: type 0
debug3: send_rexec_state: done
debug1: rexec start in 4 out 4 newsock 4 pipe -1 sock 7