Subject: force dependancy
To: None <>
From: <>
List: tech-pkg
Date: 11/18/2004 19:05:50

I am not sure if this question will not be answered, because I would
assume this information is on the web somewhere. I just wish that I could
find it.

I would like to build php4-gd without x11. I was able to do this with
ImageMagick-5.3.9nb1 by editing the pkgsrc Makefile (For the first time
ever convert is working). I have a couple of problems when I edit the gd,
and php4-gd Makefile. If I edit the pkgsrc Makefile for gd or php4-gd,
then it still says it needs x11. I just used cvs to update my pkgsrc, and
tried building php-gd, but it wants to remove ImageMagick (which I finally
got working). I know this may not really be the proper way to do things,
but is there anyway that I could force php-gd to build and use an older
version of its dependancy?