Subject: Re: Problem with PostgreSQL support in php4
To: Chris Ross <>
From: Jaromir Dolecek <>
List: tech-pkg
Date: 11/17/2004 12:42:44
Chris Ross wrote:
>    I am running code that I was running on another server (which was 
> using
> an older php4, for that matter), and when I've moved it to the new 
> server,
> the calls to pg_affected_rows() (after getting a result from a 
> pg_query())
> spits the following message into the error log:
>    PHP Warning:  pg_affected_rows(): Not supported under this build in 
> /data/.../response.php on line 179, referer: XXXX

Which version of postgresql client package do you have installed?
It appears to require PQcmdTuples(), which might be only
available in PostgreSQL 7.4.

Jaromir Dolecek <>  
-=- We should be mindful of the potential goal, but as the Buddhist -=-
-=- masters say, ``You may notice during meditation that you        -=-
-=- sometimes levitate or glow.   Do not let this distract you.''   -=-