Subject: Re: depending on both perl and perl-thread harmful?
To: None <>
From: Eric Gillespie <>
List: tech-pkg
Date: 11/15/2004 16:54:05
Pavel Cahyna <> writes:

> I had problems with p5-subversion described in
> .

Thanks for the report.  Sorry for overlooking it.

> 1/ why does p5-subversion specify that it needs perl or perl-thread when
> it is actually incompatible with perl?

Because this is news to the maintainer (me :).  I see that all my
systems have perl58-thread.  However, i have been using
p5-subversion with no trouble since before perl58-thread existed.

> 2/ why does the swig-perl package register dependency on perl or
> perl-thread if it can work correctly only with that one it was built
> against?

Because if you have no perl installed, it doesn't care which one
gets installed so long as it is >= 5.8.  Maybe i need to do
something else to make sure it picks up at run-time the same
version it found at build time?

Eric Gillespie <*>