Subject: Re: databases/openldap - BerkeleyDB version incompatible
To: None <>
From: Simon Burge <>
List: tech-pkg
Date: 11/15/2004 11:00:13
MLH wrote:

> ===> Configuring for openldap-2.2.13nb4
> ...
> checking for db.h... yes
> checking for Berkeley DB link (default)... yes
> checking for Berkeley DB thread support... no
> checking Berkeley DB version for BDB backend... no
> configure: error: BDB: BerkeleyDB version incompatible
> *** Error code 1

I'm seeing the same error here.  Backing out the last change to the
openldap Makefile:

  revision 1.85
  date: 2004/11/08 18:42:08;  author: tv;  state: Exp;  lines: +3 -4
  Allow bdb backend support to be optional via PKG_OPTIONS.openldap.  For now,
  it is still on by default to preserve compatibility (use option "-bdb" to

gets openldap building again for me.  I guess somehow the "still on by
default bit" didn't work.

I've opened a PR for this (pkg/28317).

Simon Burge                            <>
NetBSD Support and Service: