Subject: Re: graphics/php-gd dependencies
To: Krzysztof Kotlenga <>
From: Jaromir Dolecek <>
List: tech-pkg
Date: 11/12/2004 20:06:19
Krzysztof Kotlenga wrote:
> No reaction from you. Why? Is using, where it is possible, bundled
> versions of libraries a rule in pkgsrc? 

I've not seen your original mail.
> Please consider my patch. I do not want building php-gd which depends on
> a huge xpm/X11 and I have graphics/gd already installed! (without X11)

If you look at PHP GD module documentation, they claim it contains
some extras such as alpha blending support. AFAICS the 'base' GD
has all the items now too.

As for XPM, graphics/gd used to have that support too and it was
removed quite recently (2004/06/20, Makefile rev. 1.54). I'll follow
the suit with php-gd too (the dependency bothered me too).

I'll look if there are any real feature differences between
the PHP-bundled GD and "standard" GD. If there is no difference,
I'll change php-gd back to use graphics/gd.

Jaromir Dolecek <>  
-=- We should be mindful of the potential goal, but as the Buddhist -=-
-=- masters say, ``You may notice during meditation that you        -=-
-=- sometimes levitate or glow.   Do not let this distract you.''   -=-