Subject: Re: pkgsrc trouble list for solaris
To: Gavan Fantom <>
From: Robert Lillack <>
List: tech-pkg
Date: 11/05/2004 20:17:29
Gavan Fantom wrote:

> * It might be easier to set USE_PKGSRC_GCC=yes and GCC_REQD?=3 rather than 
> directly including the gcc3 .mk files.

Good point, thanks.


> * sylpheed-gtk2 - does setting LDFLAGS.SunOS+= -lsocket -lnsl -lX11 in the 
> package Makefile help?

Yes, please commit that.

> * libgcrypt - I fixed a problem with gcc on SPARC on the 25th Oct. Are you 
> sure you have this patch?

You're right. I seem to have missed that one because I did not remove my own
patches before cvsuping. This *may* fix pkg/27211, too.

> * kdelibs3 - I've had some success building this with gcc on Solaris 10 
> recently. I've committed all my patches.

Well, looks to me like the 'gsed error' again. I am building with USE_GNU_TOOLS=sed
ATM but this may take some time ....

Cheers, Rob.
  +- Robert Lillack ------------------ -+
 /  Max Planck Institute for Mathematics in the Sciences  /
+- Leipzig, Germany ----------- phone: +49-341-9959-693 -+