Subject: Re: CVS commit: pkgsrc/www/ap-php
To: grant beattie <>
From: Jaromir Dolecek <>
List: tech-pkg
Date: 11/05/2004 18:08:39
grant beattie wrote:
> this change means that we can no longer build separate, distinct binary
> pkgs for both ap-php4 and ap-php5. this is bad, especially for
> providing binary packages to end users, and the two packages should
> remain separate.

The distinct binary packages ap-php-4.3.9 and ap-php-5.0.2 would
be made as side product if php4-extensions and php5-extensions
meta packages, don't they?

My main objective to have pkgsrc fully usable with PHP 5.x, i.e.
only require PHP4 depends for stuff which really works only with
PHP4, such as php4-apc and the like. It's also convenient if 'make
update' in lang/php5/ works to upgrade from a PHP 4.x installation,
or vice versa for downgrade.

Jaromir Dolecek <>  
-=- We should be mindful of the potential goal, but as the Buddhist -=-
-=- masters say, ``You may notice during meditation that you        -=-
-=- sometimes levitate or glow.   Do not let this distract you.''   -=-