Subject: pkg_install and make update
To: None <>
From: Martti Kuparinen <>
List: tech-pkg
Date: 11/02/2004 08:47:46
Why can't I update my pkg_install any more?


ROOT backup:/usr/pkgsrc/pkgtools/pkg_install> make update
===> Installing for pkg_install-20041101
===> pkg_install-20041031 is already installed - perhaps an older version?
*** If so, you may use either of:
***  - "pkg_delete pkg_install-20041031" and "/usr/bin/make reinstall" to 
upgrade properly
***  - "/usr/bin/make update" to rebuild the package and all of its dependencies
***  - "/usr/bin/make replace" to replace only the package without re-linking
***    dependencies, risking various problems.
*** Error code 1