Subject: mysqlcc broken by recent upgrade to mysql 4.1.x
To: None <>
From: Chris Wareham <>
List: tech-pkg
Date: 10/30/2004 21:38:09
As the subject says, the recent switch to mysql 4.1.x has broken
databases/mysqlcc. I didn't look at fixing it, because it is no longer
being developed by MySQL AB. They are now concentrating on
mysql-administrator. I took a quick stab at making a package for
mysql-administrator (which depends on gtkmm rather than wxGTK).
Unfortunately it bails out with an error compiling
I've included a cut down copy of the errors from g++ below:

In file included from /usr/include/g++/bits/locale_facets.tcc:41,
                  from /usr/include/g++/locale:47,
                  from /usr/include/g++/bits/ostream.tcc:37,
                  from /usr/include/g++/ostream:535,
                  from /usr/include/g++/iterator:70,
                  from /usr/pkg/include/gtkmm-2.0/glibmm/arrayhandle.h:24,
                  from /usr/pkg/include/gtkmm-2.0/glibmm.h:26,
                  from util.h:7,
                  from myadmin.h:23,
/usr/include/g++/cmath:107: error: `acosf' not declared
/usr/include/g++/cmath:110: error: `asinf' not declared

(further complaints about math functions omitted)

/usr/include/g++/cmath: In function `float std::acos(float)':
/usr/include/g++/cmath:184: error: `acosf' undeclared in namespace `
/usr/include/g++/cmath: In function `float std::asin(float)':
/usr/include/g++/cmath:204: error: `asinf' undeclared in namespace `

(further complaints about math methods omitted) In member function `bool
    MAServerLogsPanel::process_logs(MAServerLogsPanel::LogType)': error: `strptime' undeclared (first use this
    function) error: (Each undeclared identifier is reported 
    once for each function it appears in.) includes math.h, but it wasn't wrapped in an extern
"C" block. Thinking to myself that would fix it, I added the extern "C"
block around the handful of C headers included in the file. Still no
luck. I changed the included to the cmath, etc. Still no luck.

Has anyone seen this kind of error before, as I'm stumped but would
really like a nice GUI frontend to MySQL!