Subject: Re: audio/flac broken with 2.0
To: Adam Ciarcinski <>
From: Michael <>
List: tech-pkg
Date: 10/18/2004 16:57:19

> > Another problem - audio/flac, which is needed for vorbis-tools, is broken 
> > with 2.0 on macppc. Current pkgsrc, 2.0 release, macppc.

> It has to do something with the assembler on NetBSD-macppc, since it 
> compiles without problems on MacOSX.
> Please, do not fix it by removing PowerPC code.

No, it has to do with Apple's assembler which is not compatible to the GNU assembler used by NetBSD. Maybe someone with PowerPC assembler knowledge could rewrite the code in a form gas can understand ( shouldn't be too difficult, probably only a few syntax differences ). 

have fun