Subject: Re: Package update disaster
To: Todd Vierling <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 10/09/2004 15:54:40
netbsd-users removed from CC.

Since perl was mentioned ...

perl does have a problem. Its open-ended dependencies assumes that perl
packages are interchangable with perl 5.8 and perl 5.6. This has caused
problems for me on a few occassions on systems where I use packages but no

I never send-pr'd it but I have mentioned it a couple times before. Can we
get rid of the open-ended dependencies?

The DEPENDS should probably be more precise like like perl-5.6.* or

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links