Subject: Re: net/net-snmp build failure on darwin
To: Adrian Portelli <>
From: Mark E. Perkins <>
List: tech-pkg
Date: 10/08/2004 12:57:09
On 10/8/04 11:48, Adrian Portelli wrote:

> Just to update I can build it without any issue from pkgsrc updated a 
> few minutes ago.  I updated to libtool-base-1.5.10nb1 before doing the 
> build.
> HTH,
> adrian.
> Mark E. Perkins wrote:
>> I'm trying to update net/ethereal, which requires net/net-snmp, and I 
>> get the errors shown below during the net-snmp build. Problem is that 
>> I can't find where the undefined symbols should actually be defined.
>> I have a (semi-urgent) need for ethereal, so was hoping someone has a 
>> quick fix for this.
>> This is Darwin 7.5.0 / MacOS X 10.3.5, pkgsrc updated yesterday (6 Oct).
>> Any clues?
>> Thanks,
>> Mark

<errors snipped>

hmmmm.... I just updated pkgsrc but still ran into the same errors. I had 
already updated to libtool-base-1.5.10nb1 before my first attempt/error, so 
that's not the problem....

It occurs to me that the last I built net-snmp successfully was probably 
before updating to Apple's XCode 1.5, so I'm gzipping up my disk image so I 
can try it on a machine with an older XCode (1.1, I think). We'll see what