Subject: Maybe related to the gle failure-to-build?
To: None <>
From: Richard Rauch <>
List: tech-pkg
Date: 10/07/2004 10:49:57
I recently was trying to (re)build audacity on my now 2.99.9 NetBSD box.
(At least it *should* be 2.99.9; I did a install recently.

audacity fails in*/lib-src/soundtouch while trying to
configure.  Here are some interesting lines from that directory's
config.log.  The end lines are familiar from the gle problems, but
the first feq lines that I am pasting have not been mentioned before,
that I've seen:

 /~~~ excerpt from config.log

gcc version 3.3.3 (NetBSD nb3 20040520)
configure:1241: $? = 0
configure:1243: gcc -V </dev/null >&5
gcc: couldn't run `/usr/bin/x86_64--netbsd-gcc--I/usr/pkgsrc/audio/audacity/work.x86_64/.buildlink/include': No such file or directory
configure:1246: $? = 1
configure:1266: checking for C compiler default output
configure:1269: gcc -O2 -I/usr/pkg/include -DGLX_GLXEXT_LEGACY -I/usr/include -I/usr/pkg/include/freetype2 -I/usr/pkg/include -DGLX_GLXEXT_LEGACY -I/usr/include -I/usr/pkg/inclu
de/freetype2 -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/lib -Wl,-R/usr/lib -L/usr/X11R6/lib -Wl,-R/usr/X11R6/lib conftest.c -lintl -lmad -lvorbisenc -lvorbisfile -lvorbis -logg -L
/usr/pkg/lib -pthread -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/X11R6/lib -Wl,-R/usr/X11R6/lib -lwx_gtk2 -Wl,-R/usr/pkg/lib -Wl,--export-dynamic -pthread -L/usr/pkg/lib -lgtk-x11
-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -lpng -ljpeg -ltiff -lz -lintl -Wl
,-R/usr/pkg/lib -Wl,--export-dynamic -L/usr/pkg/lib -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lportaudio >&5
/usr/pkgsrc/audio/audacity/work.x86_64/.buildlink/lib/ undefined reference to `operator new(unsigned long)'
/usr/pkgsrc/audio/audacity/work.x86_64/.buildlink/lib/ undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
/usr/pkgsrc/audio/audacity/work.x86_64/.buildlink/lib/ undefined reference to `operator delete(void*)'

 \___ excerpt from config.log

Note the unusual command, "/usr/bin/x86_64--netbsd-gcc--I/usr/pkgsrc/..."

Maybe that should be "/usr/bin/x86_64--netbsd-gcc -I/usr/pkgsrc/..."?

Checking against *.orig files, I see no indication that this is a
result of a patch.

I updated via CVS both audacity's pkg directory and ...pkgsrc/mk.

I also tried updating wxGTK (which built without a hitch), and have
of course done "make clean && make" on audacity, so it's not got
cruft from prior builds.  I also tried the "USE_LANGAUGE= c c++"

This built for me in 2.0H (same AMD64), and built also for me on
a 2.0 beta system (i386 in that case).

The trailing errors sound like the gle problem (it ends up saying
that the C compiler cannot produce an executable).

If this is related to what has already been discussed, is there a
PR to which I should attach some of the above info?  Or should I
just sit tight?


  "I probably don't know what I'm talking about."