Subject: Re: openoffice-linux
To: Paul (NCC/CS). <>
From: Michael Rauch <>
List: tech-pkg
Date: 10/06/2004 10:44:37

On Wed, Oct 06, 2004 at 03:17:34PM +1000, Paul (NCC/CS). wrote:
> - i have /emul/linux/etc/mtab no problem.
> - i patched the linux_file.c with the _pread and the _pwrite.
> i recompiled the kernel and installed.
> - i tried it again. The result is exactly the same. No change.
> Do you have any other suggestions?

can you please run 

ktrace -di -t cens /usr/pkg/bin/soffice

and send me the output (maybe via private mail, this is probably too big
for the list)? 
This might give a clue where exactly the failure happens. 

> Does anyone else have open office on their 1.6.2 install working?

I have done a quick test (make install and typing a sentence in OOo Writer)
before updating the package and it worked.

Btw, the native openoffice package doesn't work on 1.6.2 for a combination
of different reasons: At the time I created the package 1.6.2 was missing a
feature in the dynamic linker that openoffice used, but which has been
pulled up in the meantime. Then it must use the GNU-pth pthreads
implementation which is non-preemptive and the program may lock up
occasionally. On 2.0 we have a native pthreads implementation which is
preemptive ans so this problem doesn't occur any more.