Subject: Re: openoffice-linux
To: Michael Rauch <>
From: Paul (NCC/CS). <>
List: tech-pkg
Date: 10/06/2004 15:17:34
Hi Micheal,

- i have /emul/linux/etc/mtab no problem.

- i patched the linux_file.c with the _pread and the _pwrite.
i recompiled the kernel and installed.

- i tried it again. The result is exactly the same. No change.

Do you have any other suggestions?

Does anyone else have open office on their 1.6.2 install working?

Other help???

I think this is really important. NetBSD needs to have a working
wordprocessor because our work environments even if we are
programmers or sysadmins require us to be able to read and write
these wretched documents.  We don't want to be forced into a
windoze environment just because of this.

any help appreciated.


Michael Rauch wrote:

> Hi,
> On Tue, Oct 05, 2004 at 12:43:32PM +1000, Paul (NCC/CS). wrote:
> > I wonder can someone help me please, I have 1.6.2 on i386
> > and I can't get a wordprocessor to work.
> >
> > I installed openoffice-linux successfully.
> > But when I run soffice as the instructions say, I get :
> > "The application cannot be started.
> > "The configuration service is not available.
> > " Start the setup to repair blah blah...
> >
> > So I start the setup pgm and it says it has repaired
> > successfully.
> >
> > But when I re run soffice again I get the same error
> > message as before.
> does /emul/linux/etc/mtab exist (its content doesn't matter)?
> If it does, can you try to compile a kernel with the patch from rev. 1.61 to
> 1.62 of src/sys/compat/linux/common/linux_file.c applied (i.e. in this file
> replace the "sys_read" in line 983 by a "sys_pread" and the "sys_write" in
> line 1008 by a "sys_pwrite") and try again?
> Cheers
> Michael



Australian Bureau Of Meteorology