Subject: Re: ImageMagick's patch-aa
To: Adam <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 10/05/2004 17:00:26
On Wed, 6 Oct 2004, Adam wrote:

> > bash: syntax error near unexpected token `fi'
> >
> > Can we just remove all three lines?
> I guess we can.  This patch prevent installing/overwriting libltdl.

Okay I did this.

> > (By the way, I am testing the build of ImageMagick without any X
> > libraries and got rid of wmf's use of libXpm.)
> Can you possibly fix that as well?

I am still testing. Does anyone know if ImageMagick really needs X?

When build with X it uses several X libraries.

But I have now built and installed it without any X.

And I can successfully "convert" too and from XBM and XPM formats without
any X (and I don't have any libXpm).

I am not able to convert to XWD format though.
 convert: no encode delegate for this image format `test.xwd'.
 convert: no decode delegate for this image format `test.xwd'.

Maybe this could be some build option: with or without X?

(Or some new setup?)

But maybe that is some other problem because
ImageMagick-6.1.0/coders/xwd.o was built.

Anyone else have opinions on this?

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links