Subject: Re: SunOS-5.9: Permission denied
To: Hubert Feyrer <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 10/05/2004 09:02:22
On Tue, 5 Oct 2004, Hubert Feyrer wrote:

> On Tue, 5 Oct 2004, Jeremy C. Reed wrote:
> >> I've had to rebuilt all (ALL!) my pkgs built on 2.0_BETA too, after I
> >> discovered that pkg_add now complains when you add such a pkg to a 2.0_RC2
> >> system (and will do so on a 2.0 release system too); This needs fixing...!
> >
> > Did you have to rebuild? I thought it just complains but should continue.
> Yeah, so? Do you want to have "official" 2.0 binaries that lead to
> complaints by pkg_add that it's not 2.0? No, please...

I understand that the complaint is bothersome and should not be there.

I was just confirming that it complained versus not allowing it to install
in the first place for you. I read your posting to say that you couldn't
install because you wrote you "had" to rebuild.

> > I have same problem under Linux because I use a variety of packages made
> > and used on different Linux 2.6.x systems.
> That test should probably know a bit more about OS compatibility - e.g.
> that on NetBSD 2.0, 2.0_BETA and 2.0_RCx are compatible (and maybe even
> 2.*).

I agree.

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links