Subject: APR_USE_DB4 changes and libdb4 needed?
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 10/01/2004 18:45:26
I was building apache2 package today (in attempt to upgrade to latest
release for pkgsrc). It failed with missing libdb4. It was not

But work.rainier/.buildlink/bin/apu-config included -ldb4 in the LIBS.

I see that ../../devel/apr/ has:

.if !empty(APR_USE_DB4:M[yY][eE][sS])
.  include "../../databases/db4/"

And I recalled that mk/ was recently changed: "Make
APR_USE_DB4 default to NO everywhere".

rainier:/usr/pkgsrc/www/apache2$ make show-var VARNAME=APR_USE_DB4

I have apr- I am running i386.

Why does my apu-config have LIBS="-ldb4 -lexpat" ??

 Jeremy C. Reed

 	  	 	 technical support & remote administration