Subject: Re: Usefulness of pkgviews vs pkg_hack
To: Rhialto <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 09/30/2004 20:45:12
On Fri, 1 Oct 2004, Rhialto wrote:

> to do so: expat-1.95.8nb1 which is a newer version and not in the
> default view, has registered that it is required by pango-1.6.0 which is
> also not in the default view. Hey but I do see something strange:
> /usr/pkg/packages/pango-1.6.0/+BUILD_INFO contains dependencies on BOTH
> versions of expat:
> REQUIRES=/usr/pkg/packages/expat-1.95.7/lib/
> REQUIRES=/usr/pkg/packages/expat-1.95.8nb1/lib/

I think the REQUIRES= mechanism is broken. I don't even thing it is used
for anything. See @blddep and @pkgdep in the +CONTENTS file instead.

> I suppose that's not intended?)

It seems this may be caused that it depends on fontconfig which depends on
expat which has:

BUILDLINK_DEPENDS.expat+=       expat>=1.95.7
BUILDLINK_RECOMMENDED.expat+=   expat>=1.95.8nb1

I don't know why. And I don't know why it is registered as a dependency in
the package meta files either especially since the libraries do not need
expat (as shown by objdump).

One of my systems it is not a dependency and the other it is. So I
reinstalled (using new libtool-to-be-added-soon) and it doesn't depend
(@pkgdep) on expat anymore.

Can someone look at that REQUIRES= in mk/ I don't think it
should list the recursive requirements. In this case of pango it is wrong
to list expat.

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links