Subject: Re: subversion-base not building with latest buildlink/wrapper
To: Juan RP <>
From: Johnny C. Lam <>
List: tech-pkg
Date: 09/21/2004 18:59:09
On Tue, Sep 21, 2004 at 06:02:55PM +0200, Juan RP wrote:
> Hi, pkgsrc updated some minutes ago:
> cd subversion/libsvn_subr && /bin/sh
> /usr/pkgsrc/devel/subversion-base/work/subversion-1.0.7/libtool --silent
> --mode=link gcc  -O2 -pipe -march=athlon-xp -Os -I/usr/pkg/include
> -I/usr/pkg/include/db4 -I/usr/include   -pthread  -L/usr/pkg/lib
> -Wl,-R/usr/pkg/lib -L/usr/lib -Wl,-R/usr/lib     -L/usr/pkg/lib  -rpath
> /usr/pkg/lib -o auth.lo cmdline.lo config.lo config_auth.lo
> config_file.lo config_win.lo date.lo error.lo hash.lo io.lo md5.lo opt.lo
> path.lo pool.lo quoprint.lo sorts.lo stream.lo subst.lo svn_base64.lo
> svn_string.lo target.lo time.lo utf.lo utf_validate.lo validate.lo xml.lo
> /usr/pkg/lib/ -ldb4 -lexpat /usr/pkg/lib/ -lm -lcrypt
> -lresolv -lpthread cd: can't cd to
> _bUiLdLiNk__usr_pkgsrc_devel_subversion-base_work_.buildlink#/lib.: Can't open
> _bUiLdLiNk__usr_pkgsrc_devel_subversion-base_work_.buildlink#/lib/libaprutil-0.
> la cd: can't cd to
> _bUiLdLiNk__usr_pkgsrc_devel_subversion-base_work_.buildlink#/lib.: Can't open
> _bUiLdLiNk__usr_pkgsrc_devel_subversion-base_work_.buildlink#/lib/
> libtool: link: cannot find the library
> `_bUiLdLiNk__usr_pkgsrc_devel_subversion-base_work_.buildlink#/lib/libaprutil-0
> .la'*** Error code 1

I'm guessing that the in your buildlink directory for
subversion-base has funny lines in it.  Can you verify this?


	-- Johnny Lam <>