Subject: Generating .tgz With Installed Packages
To: None <>
From: Daniel Bolgheroni <>
List: tech-pkg
Date: 09/17/2004 03:31:35

after a lot of hours compiling a lot of packages with pkgsrc, I was
trying to generate .tgz with the installed packages. So, I've installed
pkg_tarup and using parameter "-a", it was created some packages like
firefox-gtk2-0.9.3, abiword-2.0.5, sylpheed-0.9.12, etc. and these files
were stored in a directory, all together.

So, testing, I tried to install these packages with "pkg_add" after a
new installation. It was installed successfully. But, going on, I
deinstalled all of them and tried again. Doing this, I get a lot of
messages that dependencies can't be loaded and some other messages like

OK, I reinstalled NetBSD, and now, even with a new installation, I get
the same errors. I don't have any idea of what's this problem, and why
they were installed succesfully once. It's very strange.

I've create these .tgz with:

# pkg_tarup -a -d . [package_name]

What's wrong? Is it because a trick I forgot creating them? What about
the system?

I'm running NetBSD/i386 1.6.2.

P.S.: Strangely, I'm getting the hostname set to "linux", even don't
changing anything. This is another "problem" I've noticed. I wouldn't
notice if hostname was set to "netbsd".

Thank you.