Subject: Re: pkgsrc NetBSD 1.6.2/i386 bulk build results 2004-09-11
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 09/11/2004 11:03:36
On Sat, 11 Sep 2004, Havard Eidnes wrote:

> > > print/scribus            
> >
> > Before looking ... this is probably because it needs gcc3 (since that
> > happened to me several times). It only works if qt3-libs is built with
> > gcc3 also.
> >
> > I guess scribus should be marked as not for NetBSD 1.6.x until this is
> > fixed. Or somehow check the GCC and mark it broken for gcc 2.
> If this is indeed the problem, would it not be better to mark the
> associated packages with the appropriate GCC_REQD variable setting?

I am not sure how we easily could. What if qt3-libs was previously

We don't have any easy mechanism for saying this qt3-libs was for gcc 2
and this one is for gcc 3 other than qt3-libs may or may not have a
dependency on a gcc3-c++ package (but only if that is used because if
using native gcc3 there is nothing recorded).

 Jeremy C. Reed

 	  	 	 BSD News, BSD tutorials, BSD links