Subject: openoffice-linux suggestions
To: None <>
From: Jeremy C. Reed <>
List: tech-pkg
Date: 09/01/2004 12:45:58
(I blind carbon copied the maintainer too.)

I had mentioned that I am working on building openoffice from source under
Linux. Well it doesn't work for me when buildlinking, but building with
dmake directly in source ${WRKSRC} is working. I have not completed a
build yet. This has been going for days ... Sure wish that openoffice
didn't bundle in tons of code from other projects.

Anyways installing and packaging openoffice-linux under Linux worked. I do
have some suggestions:

1) maybe should be renamed s/openoffice-linux/openoffice-bin/

So under Linux this would be clear that this is the binaries direct from Prior art is www/firefox-bin, www/firefox-gtk2-bin and

2) Installer failed but continued to successfully (so it thinks) to

Installation starting, please be patient ...
glibc version: 2.3.2

Initializing installation program...................not enough space on the dest
ination drive
ExitCode: 20

Installation Completed
/bin/rm -f /usr/bin/soffice.orig

It should stop the pkgsrc install if it can.

3) soffice script assumes mktemp is available. Maybe rewrite or DEPEND on

/usr/bin/soffice: line 1: mktemp: command not found
/usr/bin/soffice: Can't create temp file, exiting...

(I can provide a workaround.)

4) Installation said:

unpack file: /usr/OpenOffice.org1.1.2//home/reed/.gnome/apps/ 1.1.2/
unpack file: /usr/OpenOffice.org1.1.2//home/reed/.gnome2/vfolders/applications/

What is this? I don't see these files there or in my home.

5) Also the installer has some backup problem:

lrwxr-xr-x  1 root root   40 Sep  1 11:32 /usr/bin/soffice.orig.orig.orig -> /usr/OpenOffice.org1.1.2/program/soffice

(Please note I am using /usr as my LOCALBASE. This got me thinking ...
/usr/Software looks strange. Maybe we could have some variable to choose
alternative LOCALBASE for packages that install like this:
misc/openoffice-linux, gcc3, guile, qt3, tct, xcdroast... I am not sure

6) Also please add explanation to Makefile or DESCR to indicate what that
services.rdb file is for.

7) If setup fails in soffice it still tries to run:

./setup -nogui -r:/tmp/soffice.16262/soffice

/usr/OpenOffice.org1.1.2/program/setup.bin: error while loading shared
libraries: cannot open shared object file: No such file or

Done.  Starting OpenOffice ...
/usr/bin/soffice: line 64: /home/reed/OpenOffice.org1.1.2/soffice: No such
file or directory

8) The problem above is caused because Linux systems assume that
/usr/X11/lib is included in /etc/

  export LD_LIBRARY_PATH=/usr/X11R6/lib:/lib:/usr/lib
can be added to top of soffice script.
It worked for me. And could be based on

I have now used the package on two boxes.

Thank you for listening.

 Jeremy C. Reed

 	  	 	 open source, Unix, *BSD, Linux training