Subject: problem installing pkgsrc/textproc/p5-XML-LibXML
To: None <>
From: Georg Schwarz <>
List: tech-pkg
Date: 08/22/2004 12:57:56
I'm trying to install pkgsrc/textproc/p5-XML-LibXML on IRIX 5.3. In the
configure stage I end up with

===> Configuring for p5-XML-LibXML-1.57
enable native perl UTF8
running xml2-config...untested
The installed version of libxml2 was not tested with this version of

    XML::LibXML may fail building or some tests may not pass.
    Expect strange errors and unstable scripts.

    Check the README file for more informations
looking for -lxml2... no
looking for -llibxml2... no
libxml2 not found
Try setting LIBS and INC values on the command line
Or get libxml2 from
If you install via RPMs, make sure you also install the -devel
RPMs, as this is where the headers (.h files) are.
*** Error code 2

bmake: stopped in /usr/people/schwarz/pkgsrc/textproc/p5-XML-LibXML
*** Error code 1

bmake: stopped in /usr/people/schwarz/pkgsrc/textproc/p5-XML-LibXML

libxml2-2.6.11nb1 is installed, libxml* is present unter
${LOCALBASE}/lib. Where could I set the INC and LIBS values?
I have tried to pass them as both CONFIGURE_ENV and as CONFIGURE_ARGS to
no avail.

Georg Schwarz     +49 177 8811442