Subject: problems building cross/i386-linux
To: None <>
From: David Price <>
List: tech-pkg
Date: 08/16/2004 12:17:13
 	When I try to build cross/i386-linux I get the below output.
cross/binutils builds and installs fine for me, however it does not apply 
the patch (cross/binutils/patches/patch-ak) which is nearly identical to 
the patch which fails during the install of i386-linux 
I have tried building the package on netsd 1.6.1 (i386) and 1.6ZK (i386).
With binutils 2.9.1.x the package built.


stachys: {70} make
===> Checking for vulnerabilities in 
=> Checksum OK for glibc-2.0.7-13.i386.rpm.
=> Checksum OK for glibc-devel-2.0.7-13.i386.rpm.
=> Checksum OK for kernel-headers-2.0.34-0.6.i386.rpm.
=> Checksum OK for binutils-2.15.tar.gz.
=> Checksum OK for egcs-1.1.1.tar.gz.
=> Checksum OK for egcs-1.1.1-NetBSD-19980104.diff.gz.
work.stachys -> /home/dprice/tmp/cross/i386-linux/work.stachys
===> Extracting for cross-i386-linux-
===> Required installed package cross-binutils>= cross-binutils- found
===> Required installed package rpm-[0-9]*: rpm-2.5.4nb1 found
===> Required installed package autoconf>=2.50: autoconf-2.59 found
===> Required installed package gmake>=3.78: gmake-3.80nb3 found
30465 blocks
23314 blocks
2796 blocks
===> Patching for cross-i386-linux-
1 out of 2 hunks failed--saving rejects to libiberty/strerror.c.rej
*** Error code 1

make: stopped in /home/dprice/cvs/pkgsrc/cross/i386-linux
*** Error code 1

make: stopped in /home/dprice/cvs/pkgsrc/cross/i386-linux