Subject: Re: *_OPTIONS for package options
To: Hubert Feyrer <>
From: Johnny C. Lam <>
List: tech-pkg
Date: 07/24/2004 13:32:44
On Sat, Jul 24, 2004 at 01:53:45PM +0200, Hubert Feyrer wrote:
> On Sat, 24 Jul 2004, Johnny C. Lam wrote:
> ...
> ...
> > Any thoughts as to whether this is a worthwhile change?
> How about going for
> 	POSTFIX_USE=		sasl
> and a general
> 	USE=			sasl
> ? (Yeah, greetings from gentoo :)

The implementation in uses:

	PKG_DEFAULT_OPTIONS	(global) set to global options
	PKG_OPTIONS.${PKGBASE}	(global) set to options per-pkg

	PKG_SUPPORTED_OPTIONS	(pkg) lists supported builds per-pkg
	PKG_OPTIONS		(pkg) derived from the above per-pkg

The first two are set in /etc/mk.conf (or some file included by, and the last two are set in package Makefiles (actually,
the last one is computed from the others within and is
meant to be examined within a package Makefile).

This is basically how PKG_SYSCONF* stuff works, so I think pkgsrc users
will be comfortable with the naming scheme.


	-- Johnny Lam <>