Subject: Re: getting pkgsrc to PREFER_NATIVE
To: Anthony de Almeida Lopes <>
From: Todd Vierling <>
List: tech-pkg
Date: 07/16/2004 11:33:42
On Fri, 16 Jul 2004, Anthony de Almeida Lopes wrote:

> > PREFER_* is used by in the system.
> >
> > You can not use it to choose the "perl" you want.

> is there a way to fake installs yet?

"You don't do that for Perl."  Really.  No, honestly, trust me.  pkgsrc
*needs* its own copy of perl, and there's no way around that.

(The main issue is that most perl modules installed from pkgsrc will not
have correct PLISTs -- and thus can't be properly installed or deinstalled.
There are other issues, but suffice it to say that pkgsrc cannot, and will
not, support an external perl.)

-- Todd Vierling <> <>