Subject: Re: Linux vs. gettext-lib
To: Jeremy C. Reed <>
From: Marc Recht <>
List: tech-pkg
Date: 07/06/2004 00:32:43
> My comment in converters/libiconv/Makefile says:
> "don't use PKG_SKIP_REASON yet so we can make sure the buildlinking is
> correct"

Are there problems with the pkgsrc version of gettext-lib on Linux? I'm 
using it for ages on Linux and never had a problem with it (all have glibc 

> So we need to find out why is libiconv being depended on.
> Can you check to see why the is not working for you?

I'll try to dig a bit deeper there.

> Or what is forcing that libiconv dependency?

The problem turned out to be the PREFER_PKGSRC=yes in my mk.conf. But, 
still it shouldn't fail, but install the pkgsrc gettext then...
Anyway, I've added:
PREFER_NATIVE=gettext gettext-lib libiconv
to my mk.conf and now gettext-lib gets installed from pkgsrc, but not 
libiconv.. Weird.