Subject: Re: firefox-gtk2 segfaults
To: None <>
From: Martin S. Weber <>
List: tech-pkg
Date: 06/27/2004 01:27:23
On Sat, Jun 26, 2004 at 02:46:20PM +0200, Jukka Salmi wrote:
> Hi,
> On a current NetBSD i386 system I upgraded firefox-gtk2 to version 0.9.
> After starting firefox as an unprivileged user it tries to open
> /usr/pkg/lib/firefox-gtk2/components.ini read-write and fails (the file
> has permissions 0644), and after that it dumps core:
> $ firefox-gtk2                                                                 
> *** loading the extensions datasource
> *** ExtensionManager:checkForMismatches: no access privileges to application directory!
> Memory fault (core dumped) 

I've seen that one after updating firefox08 to ff09, running as my regular user.
Simply running it again "fixed" the problem (wonders of GNU Software, cough :) 
and it has been running "stable" since then.

> When started as root firefox dump core (but the open() succeeds, of course).
> A gdb bt reveals:
> #0  0x48711214 in pthread__sched_idle2 () from /usr/lib/
> #1  0x4870f153 in pthread__upcall () from /usr/lib/
> Firefox-gtk2-0.8nb3 worked fine.

..never worked for me (using ff w/o gtk), yet ff08 didn't spit out that
error either.

-Martin (no solution at hand)