Subject: Re: pkg/26056: pgksrc/apache/subversion packages lack dependency on libiconv
To: None <>
From: Eric Gillespie <>
List: tech-pkg
Date: 06/25/2004 14:22:05 writes:

> >Description:
> Installed Apache/SVN from pkgsrc.  Build & install work ok, but
> libiconv ought to be included among the dependencies somewhere
> (see below). Otherwise, the re'll be no locale support for SVN
> clients run server-side, i.e. those clients will be unable to
> obey LC_CTYPE locale definitions and thus unable to deal with
> e.g. filenames with accented characters.

> >Fix:

> Make at least apr-util package dependent on a suitable version
> of libiconv. Not sure where to best introduce that dependency
> (i.e. apr-util, httpd, or subversion).

But Subversion does *NOT* depend on libiconv.  I have been using
it for years without libiconv installed, and i don't want to
install it now.  I can add a knob to make apr depend on libiconv,
but i don't think it should be the default.

Eric Gillespie <*>