Subject: Re: Should perl58 default to threaded under NetBSD 2.0?
To: None <>
From: Juan RP <>
List: tech-pkg
Date: 06/22/2004 10:41:14
Content-Type: text/plain; charset=US-ASCII
Content-Disposition: inline
Content-Transfer-Encoding: 7bit

On Tue, 22 Jun 2004 09:37:08 +0100 (BST)
David Brownlee <> wrote:

>  	Then we need a way to make p5-GD work on NetBSD 2.0.
>  	The four obvious options we have are:
>  	- Default to perl58-threads on NetBSD-2.0

I agree, at least it's known to work fine in i386...

>  	- Make p5-GD depend on perl58-thread, which makes for a nasty
>  	  surprise when someone installs the non threaded perl then
>  	  has to delete it and replace with perl58-thread (which by
>  	  default would involve them reinstalling all dependant packages)
>  	  when they want to install p5-GD.

This is really bad.

>  	- Remove freetype support from p5-GD
>  	- Make freetype nonthreaded, which probably involves making our
>  	  X11 tree nonthreaded.

No please :)

	Juan RP <>

Content-Type: application/pgp-signature

Version: GnuPG v1.2.4 (NetBSD)