Subject: problems with postfix (1.6.2 version) and mailman 2.1
To: None <,>
From: Steve Bellovin <>
List: tech-pkg
Date: 06/07/2004 11:10:33
I'm trying to upgrade a mailman installation to mailman 2.1, on a 
machine running 1.6.2.  I get the following error:

    Group mismatch error.  Mailman expected the mail wrapper script to be
    executed as group "guest", but the system's mail server executed the mail
    script as group "mailman".  Try tweaking the mail server to run the script
    as group "guest", or re-run configure,  providing the command line option

The postfix source suggests that it's using the gid from the mailman 
passwd file entry, rather than the group of the alias file (which is 
what google turned up).  Any obvious configuration changes?  I don't 
see anything in the mailman README.POSTFIX file that seems helpful.  
(Aside: there were similar problems with mailman 2.0.x; these were 
solved by using different alias expansions.  But mailman changed the 
way all that was done for 2.1.)

		--Steve Bellovin,