Subject: Re: pkgsrc problem: can't build abiword
To: Juan RP <>
From: Steven M. Bellovin <>
List: tech-pkg
Date: 06/05/2004 08:36:51
In message <>, Juan RP writes:
>Content-Type: text/plain; charset=US-ASCII
>Content-Disposition: inline
>Content-Transfer-Encoding: 7bit
>On Sat, 05 Jun 2004 08:11:21 -0400
>Steve Bellovin <> wrote:
>> With yesterday's pkgsrc:
>> ===> Patching for abiword-2.0.5
>> ===> Applying pkgsrc patches for abiword-2.0.5
>> ===> Overriding tools for abiword-2.0.5
>> ===> Buildlinking for abiword-2.0.5
>> gucharmap is not installed; can't buildlink files.
>> *** Error code 1
>I guess you'll have to update gucharmap, at least to 1.4.0.
>Which version do you have installed?

Hmm -- it's a more complex failure than I thought -- the build didn't 
stop as soon as I thought it would, and the error is further back.  
gucharmap isn't there because it didn't build.  It failed because 
libgnomeui didn't build.  It faild because of libbonoboui, which failed 
because of libglade2.  Not sure yet if there's further failure 

		--Steve Bellovin,