Subject: Re: buildlink3 now requires libgcrypt 1.2.0 or higher
To: Jeremy C. Reed <>
From: Todd Vierling <>
List: tech-pkg
Date: 06/01/2004 10:38:09
On Thu, 27 May 2004, Jeremy C. Reed wrote:

: By the way, if an "objdump -x" of a library shows NEEDED of a shared
: library, then should we always include the package as a dependency (add
: buildlink includes)?

I'm not sure that this is right, given that some bl3 files prepopulate "-l"
arguments (where they may not actually need to do so).  Whether or not a
dependency is "direct" is a little more subjective than that in the real

But this scheme of (manual) detection, is a close approximation of the work
needed in today's reality.  It seems "good enough" at the moment.

(I think the main problem is really that meta-packages like "gnome-libs" are
wrong and should instead be exploded into proper dependencies where they are
truly needed.)

-- Todd Vierling <> <>