Subject: Re: pkgsrc/IRIX
To: Jan Schaumann <>
From: Georg Schwarz <>
List: tech-pkg
Date: 05/29/2004 00:08:13
> I've started to put together a webpage for outstanding issues with
> pkgsrc/IRIX:

please note that the information found there refers to IRIX 6.X, probably
6.5.X only. Previous versions of IRIX considerably differ in many aspects.
I'm trying to adapt pkgsrc to compile on IRIX 5.3 for a few months now.

One difference for example is that IRIX 5.X does not use the mipspro
compilers but rather can install SGI's IDO (IRIX development options).
I have written some buildlink3 files for that cc. One problem is that it
does not come with a c++ compiler. Also, the gcc/g++ packages do not
compile yet on IRIX 5.3. I hope this is going to change with gcc 3.4.
I'll plan to test that soon. I would then still have to find out how
to best integrate it in the compiler framework.
Another open point is how to call that compiler framework. So far I go
with "ido53", but maybe someone comes up with a better name.
IDO for IRIX 5.3 is being distributed for free by SGI, BTW.

So far I have compiled about 200 packages for IRIX 5.3, most of them non-X11
though. I still have trouble with xmkmf configuration.
Bootstraping on IRIX 5.3 is also a problem since it requires some regex
implementation (GNU version does the trick) and to use pkgsrc you need
some tools from the GNU coreutils.

Georg Schwarz     +49 177 8811442