Subject: Re: buildlink3 now requires libgcrypt 1.2.0 or higher
To: Jeremy C. Reed <firstname.lastname@example.org>
From: Adam <email@example.com>
Date: 05/27/2004 08:36:15
>>> Is it okay if I add a PKGREVISION to opencdk and increase
>>> opencdk/buildlink3.mk like the following?
>>> BUILDLINK_DEPENDS.opencdk+= opencdk>=0.5.4nb1
>> Yes. And similar things should be done for all of:
> I did opencdk, but I don't have the time now to check the rest and to
> test the rest.
> For example, I don't know which of these would be broken if built
> new libgcrypt and installed and ran with old libgcrypt (or visa versa).
I suggest the following, every binary package should depend _at_least_
on the version of the other one required, at the time of build. So, if
is opencdk-0.5.4, which requires libgcrypt-any-version, and we build a
package, the binary package should NOT depend on libgcrytp-any-version,
libgcrypt-1.2.0, which was present at the time of making opencdk.
Otherwise, we can endlessly wonder which package will be backward
which one will be not, and while we are wondering, the next version is
completely different. :)
> (Looking at /usr/bin/evolution-1.4 with vim and objdump, it is only
> referenced once though, so at least three other libraries are broken
>> That's from "make show-deps PKG=libgcrypt" in /usr/pkgsrc.
As far as I remember, only libspectrum depends on libgcrypt. Fuse and
depend on libspectrum, so if you want to play with BUILDLINK_DEPENDS...
Aaargh, we spend too much time on this, while new packages and PRs are