Subject: Re: gtk2 and freetype issues
To: None <>
From: Jukka Salmi <>
List: tech-pkg
Date: 05/25/2004 22:12:41
Jeremy C. Reed --> tech-pkg (2004-05-25 12:22:37 -0700):
> So I see closed PR 25548.
> It suggests that Xft2 should be rebuilt after include/X11/Xft/Xft.h is
> patched.
> It seems like this should be automated by bumping the required version of
> Xft2 needed for gtk2.
> I have Xft2-2.1nb4 installed. It looks like the new version is
> Xft2-2.1.2nb1 and the BUILDLINK_DEPENDS.Xft2 is Xft2>=2.1.
> Probably PR 25548 should be reopened. As far as I can tell, the problem
> was not fixed.

You're right, it wasn't fixed.

Requiring Xft2-2.1.2nb1 wouldn't be enough to successfully build x11/gtk2;
Xft2-2.1.2nb1 after Tue Apr 27 15:10:51 2004 UTC (when patches/patch-aa was
added without bumping PKGREVISION) is needed.
So probably it would make sense to bump Xft2s PKGREVISION and then depend
on Xft2-2.1.2nb2.

Regards, Jukka

bashian roulette:
$ ((RANDOM%6)) || rm -rf ~