Subject: Re: How to best integrate libnbcompat? (pkgsrc/news/suck)
To: Jan Schaumann <>
From: Georg Schwarz <>
List: tech-pkg
Date: 05/22/2004 20:49:42
> No, that won't work.  For example, we have OS_VERSIONS like '1.6Z' etc.

I thought so. :-/
What's is the appropriate way to say "if it is IRIX prior to version 6"?
> > - is it a good idea to make use of LIBS=? After all, this can only be
> > done once in the Makefile
> Probably not a good idea.  You are overwriting whatever definitions may
> already be set.  Let buildlink do the right thing for you.

ok, how?

> If it's a general problem, then just patching the one package doesn't
> seem wise.  It should instead be changed in the pkgsrc infrastructure
> itself (if we want to provide support for such broken systems ;-/).

support for snprintf etc. already is in libnbcompat, so my question simply
is how to apply it for packages where it might be needed.

Georg Schwarz     +49 177 8811442