Subject: How to run GNUstep applications
To: None <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 05/15/2004 21:52:09
Hi all,

I'm trying to get some GNUstep applications to work after installing the gnustep
meta-package.  But there is no way to get them working (I'm sure I'm missing

First attempt:

openapp GNUMail

which shows a lot of messages, some of them telling that gdnc will be started
(but then, a window pops up saying it's not running).

Second attempt: try to run gdnc by hand, and then launch an application.
I run:


Which shows a warning about GNUSTEP_SYSTEM_ROOT not beeing set; it's a warning
so... tried 'ps ax | grep gdnc' and nothing showed up.

Third attempt: run the script and then try to either openapp a
program or start the gdnc server by hand:

. /usr/pkg/share/GNUstep/System/Library/Makefiles/

No luck.  gdnc is not started.  And all applications fail to start.

What am I missing?  Searched the docs in GNUstep's home page but found nothing
clear :-(


Julio M. Merino Vidal <>
The NetBSD Project -