Subject: Re: failure to detect that perl5 is already installed.
To: None <>
From: Alan Barrett <>
List: tech-pkg
Date: 05/05/2004 15:08:46
On Wed, 05 May 2004, Alan Barrett wrote:
> When trying to build pkgsrc/textproc/libxslt, I get this:
> ===> install-depends [libxslt-1.1.6] ===> Required package {perl>=5.0,perl-thread>=5.0}: NOT found
> But I already have perl-5.8.1.  Why does it think that perl-5.8.1 fails to
> satisfy the requirement for perl>=5.0 ?

I figured it out.  perl-5.8.1 was installed as an "overwrite" package,
and I was trying to build libxslt as a "pkgviews" package.  Removing the
PKG_INSTALLATION_PREFS line from /etc/mk.conf fixed it.

The pkgviews stuff is full of confusing error messages.  Another
one is "This package doesn't support PKG_INSTALLATION_TYPE=none"
when what it means is more like "This package cannot be installed
because the intersection between PKG_INSTALLATION_PREFS=pkgviews and
PKG_INSTALLATION_TYPES=overwrite is empty".

--apb (Alan Barrett)