Subject: bootstrap failing to build pkg_install on MacOS 10.3.3
To: None <>
From: Jeff Rizzo <>
List: tech-pkg
Date: 04/29/2004 12:36:59
Forgive me if I don't provide the correct info here; I'm still trying
to feel my way around MacOS.  :)

I have a -current pkgsrc tree (just cvs updated 5 minutes ago), and
a UFS partition that I'm trying to bootstrap pkgsrc on.  (I suppose
I could use the binary kit, but if there's a problem here, I'd like
to get it solved)

The command I ran to bootstrap is as follows:

sudo ./bootstrap --prefix=/Volumes/PackageTest/pkg --pkgdbdir=/Volumes/PackageTest/pkgdb --pkgsrcdir=/Volumes/PackageTest/pkgsrc

...but the process dies like this (lots of stuff elided for space;
let me know if there's anything else you need to see):

cc -DHAVE_CONFIG_H -DDEF_LOG_DIR=\"/Volumes/PackageTest/pkgdb\" -DTAR_CMD=\"/Volumes/PackageTest/pkg/bin/tar\" -DFTP_CMD=\"/Volumes/PackageTest/pkg/bin/ftp\" -I../libnbcompat -I../../libnbcompat -I. -I. -g -O2 -c ftpio.c
In file included from /usr/include/sys/poll.h:5,
                 from ftpio.c:87:
/usr/include/poll.h:84: error: redefinition of `struct pollfd'
/usr/include/poll.h:96: error: conflicting types for `poll'
../../libnbcompat/nbcompat/poll.h:69: error: previous declaration of `poll'
*** Error code 1

bmake: stopped in /Volumes/PackageTest/pkgsrc/bootstrap/work/pkg_install/lib
*** Error code 1

bmake: stopped in /Volumes/PackageTest/pkgsrc/bootstrap/work/pkg_install
===> exited with status 1

ideas, anyone?


Jeff Rizzo