Subject: more pkgsrc brokenness: X11 handling
To: None <>
From: Hubert Feyrer <>
List: tech-pkg
Date: 04/23/2004 22:25:55
I have a pkg (wip/swi-prolog-packages) that has USE_X11 set.
Trying to build it inside a small 1.6.2/i386 chroot, I get:

	# make
	===> swi-prolog-packages-5.2.13 uses X11, but "native" isn't a valid X11 type.
	*** Error code 1

Can this please be at least changed to something that leads one to a
possible solution ("Set SOMEVAR=whatever", "See ...", ...), or pick a
default that it doesn't have to complain about (*I* didn't set anything to

 - Hubert