Subject: Q. re. USE_MIPSPRO in pkgsrc/lang/perl5/Makefile
To: None <>
From: Georg Schwarz <>
List: tech-pkg
Date: 04/23/2004 16:54:37
pkgsrc/lang/perl5/Makefile (as well as pkgsrc/lang/perl58/Makefile)
checks for USE_MIPSPRO to assess whether the Mipspro compiler is being
Isn't USE_MIPSPRO considered obsolete and should be replaced by an
appropriate PKGSRC_COMPILER setting?

Also in that Makefile,  -Duse64bitint is only used for mipspro. I wonder
whether it should not be used for any IRIX compiler (e.g. also for gcc)
provided ABI is 64. 

Georg Schwarz     +49 177 8811442