Subject: esound problems
To: None <>
From: Arto Huusko <>
List: tech-pkg
Date: 04/21/2004 20:36:44

Is esound 0.2.33 supposed to work somehow? Is it supposed to work by default,
without any configuration?

I'm asking because esound does not work at all for me. I have just installed,
on empty 2.0A -current system, gnome 2.6, and started experimenting with things.
When trying to use gnome sounds (Configuration -> Sound (or whatever it is
in English)), esound *always* hangs. For example

  - Go to Config -> Sound
  - Turn on the sound server knob.
  - Go to next page, browse the sounds
  - Play something; it plays
  - Play next thing, the program hangs
    esound is either in aud_dr or aud_wr
    attaching with gdb shows either
	   or write()-esd_audio_write()-free()-free()
  - Wait for ever, esound comes back
  - Play next sound -> hang

I have

auvia0 at pci0 dev 17 function 5: VIA VT8235 AC'97 (rev 0x50)
auvia0: interrupting at ioapic0 pin 22 (irq 5)
auvia0: ac97: Avance Logic ALC650 codec; 20 bit DAC, 18 bit ADC, Realtek 3D
auvia0: ac97: ext id 5c7<AC97_22,LDAC,SDAC,CDAC,SPDIF,DRA,VRA>
audio0 at auvia0: full duplex, mmap, independent

I've done nothing to configure any audio stuff; just plain gnome 2.6 install.

I also installed audio/mad, and tried to play MP3 with "-o esd:localhost". It
played perhaps one second, and then hung up the same way as gnome stuff

I know the soundcard works fine, because I have a tracker module player
program that uses native NetBSD audio(4) interface, and it has no
problems. Oh, and madplay without -o esd worked fine, too (I guess madplay
uses oss?)

Arto Huusko