Subject: NetBSD and Java (fwd)
To: None <>
From: David Price <>
List: tech-pkg
Date: 04/17/2004 10:28:21
---------- Forwarded message ----------
Date: Fri, 16 Apr 2004 19:13:21 -0600 (MDT)
From: David Price <>
Subject: NetBSD and Java

My apologies if two copies of this message come through, I sent one with
my example attatched, but I believe it got filtered.

	 For several weeks I have been trying to get a working version of Java of at
least version 1.3.  I have tried the sun, blackdown 1.3.1 packages
on several machines running NetBSD 1.6.1 and 1.6ZK, and the sun 1.4.2_03
and 1.4.2_04 packages on 1.6ZK.  I am installing the packages as an
unpriviledged user.  COMPAT_LINUX was enabled, and the
procfs /proc procfs rw, linux line is in fstab.  The only options I am
setting after installing the packages are JAVA_HOME (set to
/home/dprice/pkg/java/<java_version>) and the path, (set to
/home/dprice/pkg/java/<java_version>/bin).  I am able to compile and run
small java programs, such as HelloWorld.  Whenever I try to compile
something, such as the linked example, which contains import statements
to user made classes, I begin to run into errors where javac is not able
to find the files that are to be imported.  This does not happen with
every imported user made file, but what seems like a nearly random
subset.  (With CLASSPATH set to the directory that contains the first
directory that makes up the package.  In the example, CLASSPATH was $HOME,
$HOME/org/emboss/gui/ was the path to the files.)

The example is available at:

	In the linked example, when I compile with CLASSPATH set as
above, javac is not able to import Moo into ScrollPanel.  I have tried
this example on slackware with java 1.3.1 and Windows XP with java 1.4.2
and both of these setups are able to import Moo without even setting
the CLASSPATH to the equivilent of $HOME.

	I believe that this is caused by a more general problem with
java or my setup, because trying to recursively add directories to jar
files, binary java 1.3.1 example file browsers, and a small test I wrote
using the class File to print files in a directory all run into similar
problems getting the contents of a directory, they are able to read only a
few, almost random, entries in a directory.

 Are there any NetBSD or java options that anyone can think of which might
cause behavior like this?

 Thank you in advance,