Subject: Re: BUILDLINK_DEPENDS.gtk2 >=2.4.0?
To: Julio M. Merino Vidal <email@example.com>
From: Rene Hexel <firstname.lastname@example.org>
Date: 04/16/2004 15:12:19
On 15/04/2004, at 5:21 AM, Julio M. Merino Vidal wrote:
> On Wed, 14 Apr 2004 20:40:04 +0200
> "Julio M. Merino Vidal" <email@example.com> wrote:
>> Though... they claim that 2.4 is _binary_ compatible with 2.2... so
>> maybe the
>> package could be modified to install a symlink between
>> and libgtk-x11-2.0.so.200, downgrade the required version, and hope
>> works? (I don't know if this could work, and it's probably late now
>> to do
> BTW, thinking a bit more... doing this will break many gnome2 packages
> really require 2.4.
Yes, in cases where a large number (the majority) of packages depend
on an updated version, the default BUILDLINK_DEPENDS should be updated
But if the reasons were just the ones you mentioned in your previous
email (major version bump, but compatible libraries)
BUILDLINK_RECOMMENDED should be updated, not BUILDLINK_DEPENDS!
Normally, this will have the same effect (rebuilding of the
corresponding package(s)), but unlike *DEPENDS, it can be overridden by
the user (who will then get a warning that the binary packages created
may be incompatible with binaries built against the recommended set of
pre-requisite packages and should therefore not be uploaded to ftp).
I have changed 'pkg_add' recently to also by default refuse to add
binary packages possibly built against non-RECOMMENDED libraries.
(This can be overridden as well, if you know what you are doing, but a
warning will always be printed).