Subject: Re: BUILDLINK_DEPENDS.gtk2 >=2.4.0?
To: None <>
From: Julio M. Merino Vidal <>
List: tech-pkg
Date: 04/14/2004 21:21:35
On Wed, 14 Apr 2004 20:40:04 +0200
"Julio M. Merino Vidal" <> wrote:

> Though... they claim that 2.4 is _binary_ compatible with 2.2...  so maybe the
> package could be modified to install a symlink between
> and, downgrade the required version, and hope everything
> works?  (I don't know if this could work, and it's probably late now to do
> it...)

BTW, thinking a bit more... doing this will break many gnome2 packages that
really require 2.4.  Also, if you wanted to do this, you would have to change
the mininum versions of glib2, atk and pango, and end up with versions out of
sync (i.e., glib2 2.2 and gtk2 2.4, which surely breaks).

Julio M. Merino Vidal <>
The NetBSD Project -